Imate Smart TV, Nest, morda Tado? Fino, kako ste ga pa priklopili?

Imate Smart TV, Nest, morda Tado? Fino, kako ste ga pa priklopili?

V Virtui IT, kjer delam, tudi sami razvijamo t. i. IoT (internet of things) rešitve, zato si domišljam, da vem približno kako se tega lotevajo tudi drugje.
Najprej par trditev:
– V razvoju naprav v raznih startup podjetjih, varnost ni prva misel ali prvi cilj razvojnega cikla produkta,
– Večina gadgetov uporablja zunanje cloud storitve za različne namene, od pridobivanja podatkov, do obdelovanja vaših podatkov,
– Večina teh podjetij mora priti na trg izredno hitro, zato je ves fokus na samem delovanju naprav, skoraj nič časa ne more ostati za varnostne teste in podobno.
– Tudi če bi naprave varnostno intenzivno testirali, bi še vedno zelo verjetno pustili mnoge varnostne lukjne odprte. Celo podjetja, ki se ukvarjajo izključno z varnostnimi grožnjami, včasih ne morejo preprečit varnostnih lukenj v njihovih izdelkih.

Kaj želim povedati? Nikakor ne dajte naprav, kot so tado, Nest, in podobne v vaše lokalno omrežje doma, še manj pa v službeno. Naredite poseben krak na vašem usmerjevalniku in spustite ven promet le na internet. Če vaš usmerjevanik takih konfiguracij ne podpira, kupite novega, strošek je zanemarljiv. Začne se pri 40€. Posebej pazite, če imate IPv6.

Za manjša podjetja in za doma priporočam Mikrotike, dobite jih tule: https://shop.virtua-it.si/mikrotik.html

Windowsi

Windowsi

Takle mail sem prejel danes:

Oj Nejc!

Pišem ti, ker me nekaj zanima. Takrat ko sem kupila moj računalnik/monitor so prišli zraven tudi windowsi8. Z njimi sem shajala do včeraj – v upanju da saj se bom navadila – ampak se ne bom in nočem ker to je pa izven vseh kategorij potrpežljivosti, ki jih jaz premorem do softvera.

Skratka, ali imam kakšne možnosti od dobavitelja dobiti downgrade na verzijo windows 7?

Draga Urša, delim tvoje mnenje, tudi jaz o tem dnevno razmišljam, ampak se mi enostavno ne da preformatirat (znova) računalnika in zato vztrajam. Sem pa vmes doma začel uporabljat Macintosha in mi je bistveno bolj všeč, tako da mislim, da bo naslednji računalnik tudi za službo kar Mac.

Nejc

 

Koper – Ljubljana – Koper z vlakom

Koper – Ljubljana – Koper z vlakom

Pendolino

Pendolino (Photo credit: Mike Knell)

V ponedeljek sem šel iz Kopra v Ljubljano in potem nazaj z vlakom. V službo za pokušino, ker smo bili čez vikend z družino v Kopru in so moji ostali. Ob 5:30.

Vlak je bil sodoben ICS, mislim da Pendolino (mimogrede, po wikipediji gre Pendolino 250km/h http://sl.wikipedia.org/wiki/Pendolino). Tisti nagibni. A kaj pomaga, ko pa vozi ves čas med 40 in 50 km/h. Na srečo je internet preko Si.mobila kar nekako delal, zato sem šel na spletno stran Slovenskih železnic in tam našel naslov nekaga piarovca. Brez jutranje kave sem mu napisal epošto:

From: Jernej Suhadolc [mailto:[email protected]]
Sent: Monday, August 13, 2012 6:05 AM
To: Tancar Marko
Subject: Dve vprašanji

Pozdravljeni,

Ravno se peljem na vašem vlaku iz Kopra v Ljubljano. Verjetno veste, da že dalj časa na vlaku ni bara, čeprav zraven peljemo »gostinski vagon«. Moje vprašanje je: Zakaj vsaj nekega avtomata s kavo in sendviči tja ne postavite?

Drugo vprašanje pa je: Kdaj mislite na vlake uvesti internet?

Hvala za odgovore,

Jernej Suhadolc

Čez pet dni je prišel odgovor:

On 17. avg. 2012, at 10:06, “Pritožbe in pohvale” <[email protected]> wrote:

Spoštovani gospod Jernej Suhadolc!

Zahvaljujemo se vam za sporočilo. Glede na čas, ko ste nam pisali predvidevamo, da ste potovali z vlakom z oznako IC 32, ki je vozil v sestavi elektromotorne garniture, ki ima tudi bife (ne gostinskega vagona), a trenutno ne obratuje. Že pred časom smo se bili primorani soočiti s težavami izvajalca gostinske ponudbe, kar posledično pomeni, da na vlaku trenutno ni gostinske ponudbe, ker pogodbeni partner ni mogel več zagotavljati gostinskih storitev v takem obsegu kot smo pričakovali. SŽ- Potniški promet d.o.o. si prizadeva, da bi v okviru možnosti v čim krajšem času poskrbeli za obnovitev gostinske ponudbe na vlakih, o čemer boste potniki obveščeni.

V sodelovanju s podjetjem Mobitel so bile opravljene meritve signala na celotnem železniškem območju Slovenskih železnic. Pokritost s signalom, ki omogoča dostop do interneta je predvsem v urbanih področjih in ne na celotnem železniškem območju kar posledično pomeni, da potnikom ne bi omogočili kakovostne storitve na celotnem potovanju in bi bili izpadi signala preveč moteči. Sledimo razvojnim tehnologijam in se trudimo našim uporabnikom nuditi čim bolj kakovostno storitev, vendar žal to vedno ni mogoče.

V upanju, da boste še naprej potovali z našimi in vašimi vlaki vas lepo pozdravljamo,

__________________________________
Branka Bjeljac
Samostojni strokovni sodelavec

SŽ – Potniški promet, d.o.o.
Kolodvorska ulica 11, 1000 Ljubljana
Tel.: +386 1 29 12 540 ; 080 19 10
Fax: +386 1 29 12 751
www.slo-zeleznice.si

Kakšni carji so na teh železnicah – ti jim daš smer in čas, oni pa sami ugotovijo, na katerem vlaku si se peljal. Kako le to zmorejo? Pa fina je tista s težavami izvjalca gostinske ponudbe, s katerimi so se morali reveži soočiti. V tem hudem pomankanju kadrov na SŽ je res nujno najemati “samostojne strokovne sodelavce” (to valjda pomeni, da je pogodbeno, ker majo tako zelo veliko dela, da vseh 10 zaposlenih piarovcev ne zmore), in se ne najde ene same duše, ki bi šla tiste kave na vlak kuhat. Kdaj se bodo pa soočili s težavami vseh “strokovnih sodelavcev”, ki jih imajo tam na renti?

Zelo fajn tudi, da bomo potniki obveščeni. Kako pa? Bodo na vrata postaje v Ljubljani nalepili listič?

Kakorkoli, poslal sem jim še tole razočarano pismo:

Pozdravljeni,

Hvala za odgovore, škoda da image tako nizke ambicije.

Ste govorili tudi s Si.mobilom? Prepričan sem, da bi v zamenjavi za nekaj vaših lokacij za bazne postaje in uporabo nekaj optičnih vlaken, ki jih imate ob progah, z veseljem zagotovili tudi dovolj pokritosti za soliden umts signal.

Zgodbe z bifejem pa v luči števila zaposlenih na železnici raje ne komentiram.

Vašemu vodstvu pa priporočam branje twitte @richardbranson, ustanovitelja podjetja Virgin, ki trenutno še upravlja s progo London – Manchester, je pa ravnokar zgubil razpis za naslednjih 15 let. Za pomoč se url do njegovega bloga http://www.virgin.com/richard-branson/

Niti smešno ni več primerjati njegove in vaše ambicije.

Škoda.

Jernej Suhadolc

Enhanced by Zemanta

Vzdrževalna dela

Danes sem pobrisal vse neaktivne uporabnike na tem blogu, tehnične članke pa smo preselili na http://blog.virtua.si. Tam s sodelavci pišemo o tehnologiji, varnosti, IT rešitvah in podobnem, tako da ti članki bolj tja sodijo. Tule bom občasno še kaj objavil, bo pa gotovo bolj osebno. Zadnjič sem začel recimo pisati članek o tem, kakšna štala je ekonomija kot veda, pa ga potem raje nisem objavil, da ne bi bilo preveč ljudi užaljenih.

Toliko za zdaj, pridite še kaj.

IGMP Proxy

IGMP Proxy

Naslov se sliši učeno, gre pa za to, da bi radi v LAN omrežju našega doma/službe, gledali vse programe T-2 IP televizije, ne da bi pri tem preveč ogrožali varnost našega omrežja.

Kot verjetno veste, T-2, pa tudi nekateri drugi ponudniki, v optiki ali VDSL kablu, ki ga dobite do doma, prenašajo najmanj tri omrežja: internet, televizijo in telefonijo. Zanimivo je, da niti niso posebej ločena, razen da uporabljajo različna IP območja (subnets), televizija pa se prenaša v multicast načinu.

Običajna postavitev Mikrotika v vašem omrežju je verjetno taka, da lokalnim računalnikom dodeljuje privatne IP naslove (temu priključku bomo rekli LAN), zunal pa z DHCP protokolom ali statično pridobite en javni naslov (WAN). Kaj je treba torej narediti, da bi lahko denimo s programom kot je VNC predvajalnik, lahko gledali program na naslovu udp://@239.1.1.11:5000 (SLO 3 v tem primeru)?

Najprej nadgradite Mikrotik in preverite, da je tudi multicast paket v nadgradnji.

nato dodajte te ukaze:

/routing igmp-proxy interface add interface=WAN upstream=yes
/routing igmp-proxy interface add interface=LAN

Če imate pravilno skonfiguriran požarni zid – in ne dvomim, da ga imate, boste morali tja dodati naslednji ukaz:

/ip firewall filter add action=accept chain=input comment="Dovoli IGMP" disabled=no protocol=igmp

To je pa tudi vse. V VNC si naložite “play listo” s programi, pa uspešno gledanje.

Morda še dve opozorili: Vsak TV kanal zavzame širino cca 4-5 Mbps. Ko prekljapljate med kanali, se zaradi narave Multicast protokola prejšnje povezave ne zapirajo prav takoj, zato kmalu končate pri recimo 10. vzporednih TV kanalih, ki letijo čez vaš bogi Mikotik. To ga bo skoraj gotovo uničilo (resetiralo).

Za lajšanje te težave sem poskusil “fast leave” nastavitev, ki naj bi takoj zapirala nerabljene kanale, vendar ni bilo nobene razlike. Opazil sem sicer precej zavrnjenih paketov v požarnem zidu, ki imajo morda kakšno vezo s tem, vendar naprej od tega nisem prišel. če ima kdo kaj več podatkov, bom zelo vesel.
 

Enhanced by Zemanta